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Введение

Проект gEDA [1] представляет набор програм- 
мных инструментов для проектирования электрон-
ных устройств, доступных по лицензии GNU GPL. 
Это подразумевает свободу получения и модифи-
кации исходных кодов любых программ, распро-
страняемых под данной лицензией. В большинстве 
случаев, хотя и необязательно, это подразумевает 
и бесплатность. Проект gEDA — это объединение 
достаточно большого количества других проектов, 
причем после объединения ни один из них не поте-
рял своей самостоятельности. В настоящий момент 
gEDA предоставляет следующие инструменты:

Графический ввод и редактирование схем. Возможна •	
автоматическая генерация файла списков межсоеди-
нений во множестве стандартных форматов (SPICE, 
Spectre, Verilog и т. д.). Эта часть проекта разрабаты-
вается собственно сообществом gEDA.
Моделирование аналоговых и аналого-цифровых •	
схем. Доступно сразу несколько разных симуля-
торов, поддерживаемых различными группами 
разработчиков. Во‑первых, это NGSPICE [2] — 
развитие классического симулятора Spice3  f, 
с дополнительными возможностями для моде-
лирования цифровых схем и поведенческого мо-
делирования (расширение XSPICE). Кроме того, 
этот симулятор позволяет проводить совместное 
моделирование с физическими TCAD-моделями. 
Во‑вторых, GNUCAP [3] — полностью независи-
мая разработка, не основанная на исходном коде 
SPICE. Обеспечивает совместимость со Spectre 

(но не Spectre-HDL или Verilog-A) и неполную со-
вместимость со SPICE.
Графическая оболочка для симуляторов GspiceUI [4]. •	
Позволяет производить автоматическую трансля-
цию схем из формата графического редактора gEDA 
в формат файла списка межсоединений выбранного 
симулятора (NGSPICE или GNUCAP). Существенно 
облегчает доступ ко всем настройкам симулятора.
Средства разработки и моделирования цифровых •	
схем Icarus Verilog [5]. Полная поддержка стандарта 
языка Verilog IEEE Std 1364-2005. Поддержка VHDL 
отсутствует.
Отображение результатов моделирования GtkWave •	
[6].
Проектирование печатных плат. Поддерживается •	
сообществом gEDA.
Таким образом, gEDA позволяет пройти весь путь 

от разработки и моделирования устройства до его 
исполнения на печатной плате и не уступает коммер-
ческим аналогам, а в чем-то и превосходит их.

Одно из преимуществ gEDA — нулевая стоимость, 
причем пользователь получает бесплатно полнофунк-
циональные версии всех программ, без каких-либо 
ограничений. Другим, менее очевидным достоинством 
является распространение в виде исходных кодов. 
Это позволяет легко сделать gEDA основой собствен-
ной САПР, включив, например, собственные модели 
или добавив необходимую функциональность.

«Родной» операционной системой для всех инстру-
ментов gEDA является Linux, однако открытость ис-
ходного кода позволяет запустить любую програм-
му и на другой платформе. Существуют неофици-
альные сборки некоторых программ для Windows 
и Mac OS. Однако даже на «родной» платформе 
самостоятельная установка всех частей gEDA по от-
дельности — достаточно трудоемкая задача. Поэтому 
многие дистрибутивы Linux (например, Fedora, 
OpenSuse, Mandriva) предлагают решения на осно-
ве gEDA, устанавливаемые штатными средствами 
управления программами. В таком случае установка 
любых необходимых компонентов может быть вы-
полнена в несколько кликов мышкой.

Для того чтобы познакомиться с gEDA и другими 
свободными средствами САПР для проектирования 
электроники, можно воспользоваться специальным 
загрузочным диском, который подготовила группа раз-
работчиков Fedora — Fedora Electronic Lab [7]. Он по-
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Рис. 1. Полосовой фильтр Саллена-Ки
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зволяет загрузить без установки на жесткий диск 
компьютера операционную систему Fedora с за-
ранее сконфигурированными средствами САПР 
для электроники, включая gEDA. При желании 
с этого же диска можно произвести установку 
преднастроенной ОС.

Минус таких подходов к установке — отсут-
ствие тонкой настройки инструментов, воз-
можной только при компиляции программ 
из исходных кодов.

Наряду с очевидными достоинствами gEDA 
большим недостатком этого пакета средств 
САПР является разобщенность отдельных 
средств. Так как все программы разрабатыва-
ются различными сообществами, то они не об-
ладают единым интерфейсом и документа-
цией. Большинство доступных документов 
описывают отдельные инструменты или про-
граммы, тогда как для быстрого освоения 
САПР необходимо описание процесса рабо-
ты над реальным проектом, а не перечисле-
ние опций симулятора или редактора схем. 
Отсутствие единого интерфейса отталкивает 
рядового пользователя, который привык вы-
полнять все основные операции в единствен-
ном окне, переходя от одного инструмента 
к другому. Однако в действительности процесс 
создания и моделирования схем электронных 
устройств в gEDA ненамного труднее, чем 
в популярных программах типа OrCAD.

Эта статья должна дать возможность быстро 
начать работу в среде gEDA, которую можно 
рассматривать как альтернативную замену 
коммерческим программам. Естественно, что 
в одной статье нельзя рассказать обо всех воз-
можностях gEDA, поэтому в ней не говорится 
об использовании моделей, представленных 
на языках Verilog, Verilog-AMS, а также про-
ектировании печатных плат.

На примере разработки полосового фильтра 
с топологией Саллена-Ки [8] (рис. 1) мы рас-
смотрим основные моменты процесса созда-
ния и моделирования электронной схемы:

ввод схемы с использованием макромоделей;•	
оформление схемы как макромодели;•	
моделирование схемы с использованием •	
графического интерфейса и отображение 
результатов.

Системные требования  
и версии программ

Программные средства, входящие в пакет 
gEDA, поддерживаются большинством совре-
менных дистрибутивов ОС Linux, в частности 
Fedora, Mandriva, OpenSuse, Ubuntu. Работа в ОС 
Windows не поддерживается, однако возможна 
компиляция программ gEDA в среде Cygwin [9]. 
При написании этой статьи авторы использова-
ли ОС Scientific linux 6.0 (RHEL 6.0) и следующие 
версии инструментов из состава gEDA:

gSCHEM 1.6.2.20110115 — редактор схем;•	
gnetlist 1.6.2.20110115 — конвертер различ-•	
ных схемных описаний;
ngspice 22 — SPICE-симулятор;•	
gspiceui 1.0.0 — графическая оболочка для •	
SPICE-симуляторов;
gtkWave 3.3.15— программа для просмотра •	
и анализа сигналов.

Ввод схемы

Ввод схемы осуществляется с помощью 
программы gSCHEM, которая может быть вы-
звана либо из консоли командой gschem, либо 
из меню ОС Applications → Electronics → Circuit 
and PCB design → GEDA Schematic editor.

Сохраним новый файл как SallenKey.sch. 
Добавим на схему символ усилителя, для 
этого используется либо команда меню 
Add → Component, либо кнопка на панели 
инструментов. В появившемся окне Select 
Component…  переключимся во  вклад-
ку Libraries и  в  раскрывающемся списке 
Basic Devices выберем символ opamp-1.sym. 
Всегда необходимо обращать внимание 
на нумерацию ножек символа: она должна 
совпадать с порядком следования портов мо-
дели, которую вы собираетесь использовать 
с данным символом. Библиотека редактора 
схем gSCHEM предоставляет только симво-
лы элементов, процесс подключения моделей 
элементов будет рассмотрен позднее.

Для соединения элементов проводниками 
воспользуемся командой Add → Net либо кноп-
кой на панели инструментов. Для того чтобы 
присвоить имя линии связи, нужно дважды 
щелкнуть по ней левой кнопкой мыши и в по-
явившемся окне добавить значение атрибуту 
netname (поле Value), а затем нажать кнопку 
Add Value. Присваивать имена всем линиям 
связи необязательно: те проводники, которым 
не присвоены имена, получат их автоматически. 
Для переименования символа дважды кликните 
по нему левой клавишей мыши и в окне Edit 
Attributes измените атрибут refdef. Обратите 
внимание, что начальная буква имени элемен-
та (значение refdef) используется генератором 
файла списка межсоединений и, соответствен-
но, самим симулятором для идентификации 
типа модели, поэтому ее изменять не следует. 
Существуют следующие стандартные типы 
SPICE-моделей [10]:

R<имя> — резистор.•	
C<имя> — конденсатор.•	

L<имя> — индуктивность.•	
S<имя> — ключ, управляемый напряже-•	
нием.
W<имя> — ключ, управляемый током.•	
V<имя> — источник напряжения.•	
I<имя> — источник тока.•	
E<имя> — источник напряжения, управляе-•	
мый напряжением.
G<имя> — источник тока, управляемый •	
напряжением.
H<имя> — источник напряжения, управ-•	
ляемый током.
F<имя> — источник тока, управляемый •	
током.
X<имя> — макромодель (подсхема).•	
D<имя> — диод.•	
Q<имя> — биполярный транзистор.•	
M<имя> — МОП-транзистор.•	
J<имя> — полевой транзистор  •	
с p-n-переходом.
Кроме того, NGSPICE добавляет еще несколь-

ко типов для поведенческого описания схем 
и цифровых элементов [11].

Вид подготовленной для моделирования 
схемы фильтра в окне редактора принципи-
альных схем показан на рис. 2.

Привязка символов  
к моделям элементов

После того как схема введена, необходимо 
указать типы моделей используемых элемен-
тов и задать их параметры. В качестве модели 
операционного усилителя (ОУ) используем 
макромодель ОУ типа AD822A компании 
Analog Devices, скачать которую можно с офи-
циального сайта производителя [12].

Загруженный файл ad822a.cir сохраним 
в рабочей директории. Добавим к символу 
усилителя атрибут model-name с именем мо-
дели, в данном случае AD822A. Название мо-
дели можно посмотреть, открыв файл ad822a.
cir в любом текстовом редакторе. Кроме того, 
следует проверить значение атрибута refdes: 
название символа должно начинаться с «X».

Рис. 2. Схема полосового фильтра Саллена-Ки в окне редактора схем gSCHEM



Технологии в электронной промышленности, № 3’2011

www.teche.ru26

Подключим файл, содержащий описа-
ние модели усилителя, к проекту. Для этого 
в окне схемного редактора прямо на поле 
изображения схемы добавим символ spice-
include-1.sym с атрибутом file=ad822a.cir.

Встроенные модели резисторов и конден-
саторов будут автоматически привязаны 
к символам, имена которых начинаются с «R» 
и «C», генератором списков межсоединений. 
Однако необходимо задать значения параме-
тров этих моделей.

Так как схема будет использоваться как 
параметризованная макромодель, не будем 
задавать значения параметров отдельных 
элементов (резисторов и конденсаторов) чис-
ленно. В качестве параметров фильтра будем 
использовать максимальное усиление в полосе 
пропускания — Ap, а также номиналы компо-
нентов Rf, R1, R2, C1, C2. Номиналы резисто-
ров Ra и Rb зададим через величину Ap.

Рассмотрим присвоение параметризованно-
го значения номиналу резистора Ra. Дважды 
кликнем по символу резистора и в появив-
шемся окне Edit Attributes добавим атри-
бут value со значением {10e3*(Ap+1)/(2*A–1)}. 
Аналогично поступим с другими пассивными 
элементами схемы.

Оформление схемы  
как макромодели

Для того чтобы оформить схему как ма-
кромодель, необходимо добавить несколько 
SPICE-директив. Во‑первых, дадим имя новой 
макромодели. Для этого добавим в поле ре-
дактирования схемы специальный элемент — 
spice-subcircuit-LL-1.sym (Add Component → 
Libraries → SPICE simulation elements) и из-
меним его атрибуты: model-name на SallenKey 
(это имя новой подсхемы), а refdes на A1 (это 
имя экземпляра директивы SPICE).

Кроме того, добавим атрибут value со зна-
чением параметров макромодели по умол-
чанию, например: C1=3.9n C2=3.9n R1=10K 
R2=20K Ap=1. К  сожалению, последняя 
официальная версия gEDA не поддерживает 
добавление значений по умолчанию для па-
раметров макромоделей. Чтобы исправить 
этот недостаток, необходимо модифицировать 
файл /usr/local/share/gEDA/scheme/gnet-spice-
sdb.scm согласно [13].

Добавим выводы к макромодели. Для этого 
к каждому узлу, который необходимо сделать 
выводом, следует подключить компонент 

spice-subcircuit-IO-1.sym (Add Component → 
Libraries → SPICE simulation elements). Атрибут 
refdes элемента вывода отвечает за имя порта. 
Выводы должны именоваться в соответствии 
со схемой P<номер вывода>.

Для создания файла макромодели, анало-
гичного скачанному с сайта Analog Devices, 
воспользуемся входящей в состав gEDA про-
граммой gnetlist — средством конвертации 
различных схемных описаний.

Для создания модели следует ввести в тер-
минале, находясь в рабочей директории, сле-
дующую строку:

$ gnetlist -I -g spice-sdb -o SallenKey.cir SallenKey.sch

Sallenkey.cir — желаемое название файла 
текстового SPICE-описания модели фильтра, 
SallenKey.sch — созданная в gSCHEM схема. 
Полученный файл можно использовать ана-
логично файлу ad822.cir.

Создание графического изображения 
символа модели

Макромодель фильтра готова. Осталось 
создать символ для нового элемента. С этой 
целью также воспользуемся программой 
gSCHEM. Откроем gSCHEM, удалим рамку 
и сохраним новый файл как SallenKey-1.sym 
в рабочей директории. Для рисования символа 
можно пользоваться инструментами из меню 
Add, расположенными под горизонтальной 
чертой, такими как line — линия, box — пря-
моугольник, circle — окружность, ark — дуга, 
pin — вывод. Созданный символ фильтра 
Саллена-Ки показан на рис. 3. Для выводов 
нужно задать некоторые обязательные атри-
буты:

pinnumber — номер;•	
pinseq — номер для симулятора (в данном •	
случае совпадают);
pintype — тип: вход (in), выход (out), двуна-•	
правленный (io);
pinlabel — имя (для удобства использования •	
символа).
Добавим атрибуты всему символу. Для 

этого, убедившись, что ничего не выделено 
в поле редактора, выберем пункт меню Add → 
Attribute.

Необходимые атрибуты:
device•	  — имя созданного устройства, напри-
мер SallenKey;

refdes•	  — начальная буква имени SPICE типа 
устройства со знаком вопроса. Для макро-
моделей это «X?».
После того как символ нарисован, необхо-

димо убедиться, что размер сетки установлен 
в значение 100 (Options → Snap Grid Spacing), 
а также включена привязка к узлам сетки 
(Options → Toggle Snap On/Off). После этого 
выполним привязку символа к узлам сетки 
(это необходимо для корректной вставки 
символа в схему): Edit → Symbol Translate → 
offset 0. Символ готов.

Для того чтобы символ стал доступен 
из  меню gSCHEM, необходимо отредак-
тировать или создать настроечный файл 
~/.gEDA/gafrc, добавив в него строки:

;; mylib 
(component-library <Путь до рабочей директории>)

Создание тестовой схемы

Протестируем созданную модель. Для этого 
создадим новый файл в gSCHEM, например 
SallenKey_test.sch. Добавим символы создан-
ного нами фильтра и источников. Установим 
атрибут value для источника питания атрибут 
«5», для источника сигнала — «DC 0 AC 1». 
С созданной на предыдущем шаге моделью 
фильтра Саллена-Ки можно обходиться 
так же, как и с моделью усилителя Analog 
Devices. Кроме того, можно изменить значения 
параметров макромодели с помощью атрибу-
та value, например, чтобы изменить коэффи-
циент усиления фильтра, следует присвоить 
атрибуту value «Ap=<новое значение>». Вид 
схемы показан на рис. 4.

Моделирование  
тестовой схемы

Для моделирования работы схемы будем 
использовать удобную графическую оболоч-
ку gspiceui над двумя gEDA-симуляторами — 
NGSPICE [2] и gnucap [3]. Выбор симулятора 
зависит от типа решаемой задачи. Так, хотя 
симулятор gnucap и содержит некоторые до-
полнительные опции, связанные в основном 
с  поведенческим моделированием, но  он 
не полностью совместим с SPICE, таким об-
разом, могут возникнуть некоторые трудности 
с использованием моделей, которые предо-
ставляют фирмы-изготовители ИС.

Рис. 3. Символ для макромодели фильтра Рис. 4. Тестовая схема для макромодели полосового фильтра



Печатные платы

www.teche.ru 27

Программа GspiceUI может быть вызва-
на как из меню Applications → Electronics → 
GspiceUI, так и из терминала. Окно програм-
мы показано на рис. 5. Так как мы использо-
вали модель ad822, не совместимую с gnucap, 
то в качестве симулятора необходимо выбрать 
ngspice (Settings → NG-Spice).

Загрузим тестовую схему SallenKey_test.sch 
(File → Import…). Далее перейдем на вкладку 
AC и внесем необходимые настройки анализа, 
воспользовавшись интуитивно понятным ин-
терфейсом. В поле Nodes и Components можно 
выбрать узлы и компоненты схемы, на кото-
рых будет произведен расчет. Для начала мо-
делирования воспользуемся пунктом меню 
Simulate → Run. Чтобы просмотреть результа-
ты в программе gtkWave, выберем Simulate → 
Data Viewer. Появятся два окна gtkWave: одно 
с двумя пустыми полями графиков, второе — 
со списком доступных для отображения сигна-

лов. Необходимые для отображения сигналы 
перетащим мышью из второго окна в первое. 
Пример отображения результатов AC-анализа 
показан на рис. 6.

Заключение

Приведенный пример показывает, что,  
несмотря на некоторую непривычность САПР, 
gEDA позволяет выполнять достаточно слож-
ные задачи по проектированию и анализу схем 
и в целом не уступает аналогам, распростра-
няемым на коммерческой основе. Кроме того, 
пользователь сразу получает полнофункцио-
нальные версии всех программ, избавляясь 
от сложного выбора типа лицензии, количе-
ства инструментов и т. д. Это особенно удобно 
в учебном процессе, поскольку любой студент 
может повторить у себя дома лабораторную 
работу или заниматься разработкой своего 

курсового проекта, не задумываясь об огра-
ничениях пробной версии САПР.

Авторы использовали этот пакет САПР 
в лабораторных работах, проводимых в рам-
ках курса «САПР в микроэлектронике» на ка-
федре микро- и наноэлектроники МИФИ. Как 
показал опыт, использование gEDA в учебном 
процессе позволяет студентам попутно овла-
деть навыками работы в UNIX-подобных 
системах, а также глубже понять принципы 
работы инструментов САПР, благодаря необ-
ходимости работать с каждым инструментом 
отдельно. Студенты, изучившие приемы рабо-
ты в среде gEDA, на дальнейших этапах обуче-
ния быстрее осваивают сложные коммерческие 
САПР, такие как Cadence Virtuoso.	  
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Рис. 5. Окно графической оболочки gspiceui

Рис. 6. Результаты AC-анализа — АЧХ и ФЧХ полосового фильтра


